<!DOCTYPE html><html lang="en" xmlns="http://www.w3.org/1999/xhtml" xml:lang="en" xmlns:fb="http://www.facebook.com/2008/fbml"><head><meta charset="utf-8"><meta http-equiv="X-UA-Compatible" content="IE=edge"><meta name="viewport" content="width=device-width, initial-scale=1.0, maximum-scale=1.0, user-scalable=0"><title>Seven show title suggestions for Obamaflix</title><meta name="viewport" content="width=device-width, initial-scale=1"><meta property="og:title" content="Seven show title suggestions for Obamaflix"><meta property="og:description" content="Seven show title suggestions for Obamaflix"><meta property="og:image" content="https://canadafreepress.com/images/uploads/calabrese031218-4.jpg"><meta property='description' content="Seven show title suggestions for Obamaflix"><meta property="keywords" content="Seven show title suggestions for Obamaflix"><meta name="referrer" content="always"><link rel="canonical" href="https://canadafreepress.com/article/seven-show-title-suggestions-for-obamaflix" /><meta property="author" content="Dan Calabrese"><meta property="og:type" content="Seven show title suggestions for Obamaflix" /><link href="/bootstrap/css/bootstrap.min.css" rel="stylesheet"><link href="/bootstrap/css/cfp-bs.css" rel="stylesheet">
<!--[if lt IE 9]> <script src="https://oss.maxcdn.com/html5shiv/3.7.2/html5shiv.min.js"></script> <script src="https://oss.maxcdn.com/respond/1.4.2/respond.min.js"></script> <![endif]--><meta http-equiv="Content-Type" content="text/html; charset=utf-8" /><link rel="alternate" type="application/rss+xml" title="RSS" href="https://canadafreepress.com/CFP-RSS" /><link rel="alternate" type="application/atom+xml" title="Atom" href="https://canadafreepress.com/index.php/atom" /><link rel="Shortcut Icon" href="https://canadafreepress.com/favicon.ico" /><link re="stylesheet" type="text/css" href="https://canadafreepress.com/cache/3935f92b1f977cbb276317867d2387b2222370c3.1431288836.css" /><link rel="apple-touch-icon" href="somedir/touch-icon-iphone-60x60.png"><link rel="apple-touch-icon" sizes="114x114" href="https://canadafreepress.com/icons/apple-touch-icon-114X114.png" /><link rel="apple-touch-icon" sizes="120x120" href="https://canadafreepress.com/icons/apple-touch-icon-120X120.png" /><link rel="apple-touch-icon" sizes="72X72" href="https://canadafreepress.com/icons/apple-touch-icon-72X72.png" /><link rel="apple-touch-icon" href="https://canadafreepress.com/icons/apple-touch-icon.png" /><link rel="apple-touch-icon" href="https://canadafreepress.com/icons/apple-touch-icon-precomposed.png" /><link rel="apple-touch-icon-precomposed" sizes="114x114" href="https://canadafreepress.com/icons/apple-touch-icon-114X114-precomposed.png" /><link rel="apple-touch-icon-precomposed" sizes="120x120" href="https://canadafreepress.com/icons/apple-touch-icon-120X120-precomposed.png" /><link rel="apple-touch-icon-precomposed" sizes="72X72" href="https://canadafreepress.com/icons/apple-touch-icon-72X72-precomposed.png" /><link rel="apple-touch-icon-precomposed" href="https://canadafreepress.com/icons/touch-icon-iphone-precomposed.png" /><link href="https://canadafreepress.com/cache/0e82091120669b264a7c8a08e9c7e1dd787d5f7d.1378462358.css" rel="stylesheet" type="text/css" /> <script src="https://canadafreepress.com/tabmenu/tabmenu/tabmenu.js" type="text/javascript"></script> <link rel="meta" href="https://canadafreepress.com/labels.rdf" type="application/rdf+xml" title="ICRA labels" /><meta http-equiv="pics-Label" content='(pics-1.1 "http://www.icra.org/pics/vocabularyv03/" l gen true for "http://canadafreepress.com" r (n 0 s 0 v 0 l 1 oa 0 ob 0 oc 0 od 0 oe 0 of 0 og 0 oh 0 c 0) gen true for "http://canadafreepress.com" r (n 0 s 0 v 0 l 1 oa 0 ob 0 oc 0 od 0 oe 0 of 0 og 0 oh 0 c 0))' /><meta name="distribution" content="global" /><meta name="rating" content="general" /><meta name="revisit-after" content="7 days" /><meta name="robots" content="index, follow" /> <script type="text/javascript" src="//s7.addthis.com/js/300/addthis_widget.js#pubid=bthom62" async="async"></script> <script>(function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){(i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
      m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
      })(window,document,'script','//www.google-analytics.com/analytics.js','ga');

      ga('create', 'UA-6901983-1', 'auto');
      ga('send', 'pageview');</script> <style>body>img{position:absolute}.imgbig{max-width:100%;height:auto;float:none;margin:0px
0px 20px 0px}.imghead{border:1px
solid #ddd;border-radius:4px;padding:5px;width:70px;float:left;margin:0px
15px 5px 0px}.imgheadbio{border:1px
solid #ddd;border-radius:4px;padding:5px;width:120px;float:left;margin:0px
15px 5px 0px}.imgpromo{border-radius:4px;width:120px;width:120px;float:none;margin:0px
15px 0px 15px}.adbox{max-width:350px;margin:0px
20px 0px 0px;float:left}.smallpix{max-width:350px;margin:0px
20px 0px 0px;float:left}</style> <script data-cfasync="false" type="text/javascript">(function(s,o,l,v,e,d){if(s[o]==null&&s[l+e]){s[o]="loading";s[l+e](d,l=function(){s[o]="complete";s[v+e](d,l,!1)},!1)}})(document,"readyState","add","remove","EventListener","DOMContentLoaded");(function(){var s=document.createElement("script");s.type="text/javascript";s.async=true;s.src="//cdn.engine.addroplet.com/Scripts/infinity.js.aspx?guid=e6b60151-7772-43f4-b00c-c91ae2466a7c";s.id="infinity";s.setAttribute("data-guid","e6b60151-7772-43f4-b00c-c91ae2466a7c");s.setAttribute("data-version","async");var e=document.getElementsByTagName('script')[0];e.parentNode.insertBefore(s,e)})();</script> <script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script> <script>(adsbygoogle = window.adsbygoogle || []).push({
    google_ad_client: "ca-pub-2577119061684342",
    enable_page_level_ads: true
  });</script> </head><body>
<nav class="navbar navbar-default"><div class="row"><div class="container"><div class="navbar-header">
<button type="button" class="navbar-toggle collapsed" data-toggle="collapse" data-target="#bs-example-navbar-collapse-1" aria-expanded="false">
<span class="sr-only">Toggle navigation</span>
<span class="icon-bar"></span>
<span class="icon-bar"></span>
<span class="icon-bar"></span>
</button><div class="brand-wrap col-md-12"><h2 class="brand col-md-5"><a class="navbar-brand" href="/">Canada Free Press</a></h2>
<a href="#" class="byline col-md-7">Because without America, there is no free world.</a></div></div></div></div><div class="row"><div class="container"><div class="collapse navbar-collapse" id="bs-example-navbar-collapse-1"><ul class="nav navbar-nav"><li><a href="https://canadafreepress.com/" title="New, Headline News, Breaking News">Home</a></li><li><a href="https://canadafreepress.com/categories/coverstory" title="Cover Stories, Breaking stories, Top Stories, Exclusives, Front Page News">Front Page News</a><li><a href="https://canadafreepress.com/categories/american-politics">America</a></li><li><a href="https://canadafreepress.com/categories/canadian-news" title="Canada">Canada</a></li><li><a href="https://canadafreepress.com/categoriess/world" title="Canada">World</a></li><li><a href="https://canadafreepress.com/categories/guns-crime-terror-security" title="Crime,terror, Security">Crime &amp; Terror</a></li><li><a href="https://canadafreepress.com/categories/global-warming-energy-environment" title="Global Warming, Energy, Environment">Environment</a></li><li><a href="https://canadafreepress.com/categories/natural-science-technology" title="Science &amp; Technology">Science &amp; Tech</a></li><li><a href="https://canadafreepress.com/health-medicine" title="Health and Medicine">Health</a></li><li><a href="https://canadafreepress.com/Travel" title="Travel, Resorts">Travel</a></li><li><a href="https://canadafreepress.com/Automotive" title="Automotive, Car Reviews">Autos</a></li><li><a href="https://canadafreepress.com/CFP-Video-Features" title="CFP Video Feature">CFP Video Feature</a></li><li><a href="https://canadafreepress.com/categories/lifestyles" title="Lifestyles, Pets, Gardens, Food, Music">Lifestyles</a></li><li><a href="https://canadafreepress.com/categories/cartoons" title="Cartoons">Cartoons</a></li><li><a href="https://canadafreepress.com/categories/news-headlines" title="Videos">News and Videos</a></li><li><a href="https://canadafreepress.com/recent-columns" title="Recent News, most recent stories">Most Recent Stories</a></li><li><a href="https://canadafreepress.com/archives/" title="Archives">Archives</a></li><li><a href="https://canadafreepress.com/Archives-by-Columnist" title="Writer Archives">Columnists</a></li><li class="dropdown">
<a href="#" class="dropdown-toggle" data-toggle="dropdown" role="button" aria-haspopup="true" aria-expanded="false">About <span class="caret"></span></a><ul class="dropdown-menu"><li role="label"><a href="#">Home</a></li><li role="separator" class="divider"></li><li><a href="https://canadafreepress.com/About-us/" title="About us, Subscriptions">About us / FAQ</a></li><li><a href="https://canadafreepress.com/About-us/" title="About us, Subscriptions">Subscribe</a></li><li><a href="https://canadafreepress.com/Letters-to-the-editor" title="Letters to the Editor">Letters</a></li><li><a href="https://canadafreepress.com/CFP-RSS">RSS Feed</a></li></ul></li></ul></div></div></div>
</nav><div class="container"><div class="row"><div class="col-md-8">
<a href="http://whatfinger.com/"><img src="https://canadafreepress.com//resource/whatfinger.jpg" class="img-responsive" height="70" width="700" alt="WhatFinger" title="WhatFinger"></a><hr />
<a href="http://www.subscribepage.com/g4c3q7"><h4 style="line-height:3em; float:center;">Subscribe to Canada Free Press for FREE</h4></a><h4>We are the ones we've been waiting for.</h4><h1>Seven show title suggestions for Obamaflix</h1><hr><div class=""><img src="https://canadafreepress.com/images/member_photos/photo_836.jpg" class="imghead" title="CFP Columnist Dan Calabrese" rel="author" alt="Dan Calabrese image" /><p>By <a href="/members/1/Calabrese/836" rel="author">Dan Calabrese</a> &mdash;&mdash;<a href="/members/1/Calabrese/836"> Bio and Archives</a>--<em>March 12, 2018</em></p><p> <strong><a href="#Comments"><span class="spot-im-replies-count" data-post-id="98603"></span> Comments</a> | <a href="http://canadafreepress.com/print_friendly/seven-show-title-suggestions-for-obamaflix">Print Friendly</a> | <a href="https://landing.mailerlite.com/webforms/landing/o1p1n0">Subscribe</a> | <a href="/cdn-cgi/l/email-protection#cea2abbabaabbcbd8eadafa0afaaafa8bcababbebcabbdbde0ada1a3">Email Us</a> </strong></p></div><div class="addthis_sharing_toolbox"></div><div style="clear:both;"><p><img src="https://canadafreepress.com/images/uploads/calabrese031218-4.jpg" alt="Seven show title suggestions for Obamaflix" height="297" width="700" class="img-responsive" title="insert picture" /><br />
If Barack Obama is going to do a production deal to develop content for Netflix - and apparently he is - he&#8217;s going to need good advice from people with a flair for the creative. One problem for Obama is that he is not quite as cool, creative or original as he thinks he is - and he tends to be surrounded by sycophants who won&#8217;t tell him when his ideas are a little short in the quality department.</p></div><div style="clear:both;"><div class="adbox"><script data-cfasync="false" src="/cdn-cgi/scripts/d07b1474/cloudflare-static/email-decode.min.js"></script><script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>

<ins class="adsbygoogle" style="display:inline-block;width:336px;height:280px" data-ad-client="ca-pub-2577119061684342" data-ad-slot="3559556717"></ins>
<script>
(adsbygoogle = window.adsbygoogle || []).push({});
</script></div><p>Well. I&#8217;ve never flattered Barack Obama a day in my life, so there&#8217;s no reason to start now. I&#8217;m quite sure I can come up with much better show ideas than he can, and I want to help because I&#8217;m just that kind of helpful guy.</p><p>So here are seven show ideas Obama can bring to Netflix. He doesn&#8217;t have to pay me for this, although he will owe me a favor, and I will collect:</p><p><strong>Acted Stupidly.</strong> Obama reviews out-of-context video and misleading news reports of decisions people make in response to life&#8217;s challenges, then passes judgment on the wisdom of these choices. Later when it&#8217;s revealed that Obama had no idea what he was talking about, he pretends to have made amends by inviting the guy to his place for a &#8220;beer summit.&#8221;</p><p><strong>Okie Doke. </strong>Obama addresses rising phenomena within the country that he thinks represent foolishness on the part of the American people, and in an attempt to connect with the unsophisticated rubes out there, abandons all pretense of coherence and talks like this:</p><div class="embed-responsive embed-responsive-16by9"><iframe width="560" height="315" src="https://www.youtube.com/embed/v-66xJLd6Z0" frameborder="0" allow="autoplay; encrypted-media" allowfullscreen></iframe></div><p><br /><br /></p></div><div style="clear:both;"><div class="adbox"><script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>

<ins class="adsbygoogle" style="display:inline-block;width:336px;height:280px" data-ad-client="ca-pub-2577119061684342" data-ad-slot="6563395513"></ins>
<script>
(adsbygoogle = window.adsbygoogle || []).push({});
</script></div><p><strong>Pick Your Platitude</strong>. Celebrity panelists try to guess which mindless platitude Obama will use when discussing the issues of the day. Double points for &#8220;We are the change we&#8217;ve been waiting for.&#8221; Regular guest stars to include Barbra Streisand, Ed Asner and Mike Farrell. The winner of the full season standings wins the right to star in a movie in which Obama&#8217;s policies were good for the country. Then again, that&#8217;s pretty much every movie.</p><p><strong>Suck Up, Scribe!</strong> Mainstream journalists take turns asking Obama questions like, &#8220;Exactly how awesome are you?&#8221; and &#8220;How do you find peace when racist Republicans are bashing you?&#8221; and &#8220;What, sir, has enchanted you?&#8221; Fox News is not invited. But you figured that.</p><p><strong>China For A Day.</strong> Co-hosted by Thomas Freidman of the New York Times, we explore a world in which Obama doesn&#8217;t have to subject himself to horrors like the constitutional limits on his powers, and he is free to &#8220;impose the correct solutions,&#8221; not just on the United States but on the entire world. During special host segments, Friedman tries to explain what it&#8217;s like to be a bestselling author and multimillion-dollar columnist who can&#8217;t write to save his life. No one can make any sense of what he&#8217;s trying to say.</p><p><strong>Uncle Joe&#8217;s Playhouse</strong>. If it&#8217;s Obamaflix, it&#8217;s Biden Time! Joe fires bullets through doors, sits on the laps of motorcycle mamas and gropes your 13-year-old daughter, all while rolling his eyes at the attempts of frustrated co-host Paul Ryan to explain fiscal policy in America.</p><p><strong>Hag of the Hampton</strong>s. In a dark, twisted, supernatural thriller, Obama stars as a regular guy just trying to live his life, only to be haunted by a woman who thinks she was entitled to everything he&#8217;s got and is obsessed with her belief that everyone has let her down. In a bizarre twist, Obama is forced to let this woman live and work with him, and is helpless to do anything as her corruption, incompetence and general horribleness makes his life a living hell.</p><p>At the end of the final episode, the hag declares that she will be getting her own show. Obamaflix disbands entirely rather than allow that to happen.</p></div><div class="addthis_sharing_toolbox"></div>
<script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<ins class="adsbygoogle" style="display:block; text-align:center;" data-ad-format="fluid" data-ad-layout="in-article" data-ad-client="ca-pub-2577119061684342" data-ad-slot="6058632314"></ins>
<script>
     (adsbygoogle = window.adsbygoogle || []).push({});
</script><hr /><a href="/members/1/Calabrese/836">Dan Calabrese -- Bio and Archives</a> | <a href="#Comments"><span class="spot-im-replies-count" data-post-id="98603"></span> Comments</a><p><em>Dan Calabrese’s column is distributed by HermanCain.com, which can be found at <a href="https://www.hermancain.com/" rel="nofollow">HermanCain.com</a></p><p>A new edition of Dan&#8217;s book &#8220;Powers and Principalities&#8221; is <a href="http://www.dancalabresebooks.com/powers.htm" rel="nofollow">now available in hard copy and e-book editions</a>. Follow all of Dan&#8217;s work, including his series of Christian spiritual warfare novels, by <a href="https://www.facebook.com/writerdancalabrese">liking his page on Facebook</a>.</em></p><hr />
<div id='ld-sbs-cntnr'></div><script async src='https://cdn1.lockerdome.com/embeds/canadafreepress_main_content_multi_impression_unit.js'></script>
<div class="recirculation-container"></div>
<section id="Comments"><h4>Commenting Policy</h4></section>
Please adhere to our commenting policy to avoid being banned. As a privately owned website, we reserve the right to remove any comment and ban any user at any time.
<br /><br />
Comments that contain spam, advertising, vulgarity, threats of violence, racism, anti-Semitism, or personal or abusive attacks on other users may be removed and result in a ban.<br /> -- <a href="https://docs.google.com/document/d/1aI_1Cnoe8pwJIUyubyiHyGY_jcFf4rvvz0CL1ojArD8/edit?usp=sharing" rel="nofollow">Follow these instructions on registering</a>:<div class="conversation-container"></div><div data-spotim-module="recirculation" data-spot-id="sp_amADK71w"></div> <script async src="https://recirculation.spot.im/spot/sp_amADK71w"></script> <script async src="https://launcher.spot.im/spot/sp_amADK71w"     data-spotim-module="spotim-launcher"     data-post-url="https://canadafreepress.com//article/seven-show-title-suggestions-for-obamaflix"     data-post-id="98603"></script> </div>
<aside class="col-md-4 ads"><div class="row"><div class="col-md-12 col-sm-6 col-xs-12"><div><script>
  (function() {
    var cx = 'partner-pub-2577119061684342:1245485601';
    var gcse = document.createElement('script');
    gcse.type = 'text/javascript';
    gcse.async = true;
    gcse.src = 'https://cse.google.com/cse.js?cx=' + cx;
    var s = document.getElementsByTagName('script')[0];
    s.parentNode.insertBefore(gcse, s);
  })();
</script>
<gcse:searchbox-only></gcse:searchbox-only></div><br /><br />
<a href="https://canadafreepress.com/About-us/"><img src="https://canadafreepress.com//resource/judi-101616-300.jpg" class="imgbig" alt="Canada Free Press, CFP Editor Judi McLeod" title="Canada Free Press, CFP Editor Judi McLeod"></a></div><div class="col-md-12 col-sm-6 col-xs-12">
<div id="EwzPqClXi8hQiIcuzxx4whqbN152N_bKiXw4wvKH"></div>
<script src="https://s.newsmaxfeednetwork.com/static/js/connectV5.js"></script>
<script type="text/javascript">
    NM.init({
        widgetId: "EwzPqClXi8hQiIcuzxx4whqbN152N_bKiXw4wvKH",
         template: "NM22"
    });</script></div></div><div class="row"><div class="col-md-12 col-sm-6 col-xs-12">
<script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>

<ins class="adsbygoogle" style="display:inline-block;width:336px;height:280px" data-ad-client="ca-pub-2577119061684342" data-ad-slot="6953468892"></ins>
<script>
(adsbygoogle = window.adsbygoogle || []).push({});
</script></div><div class="col-md-12 col-sm-6 col-xs-12"><div class="col-md-12 col-sm-12 col-xs-12"><h3>Popular Stories</h3><div class="panel panel-default panel-news"><div class="panel-heading"><ul class="nav nav-tabs"><li role="presentation" class="active"><a href="#tabRecent" data-toggle="tab">Recent</a></li><li role="presentation"><a href="#tabNews" data-toggle="tab">News-Videos</a></li><li role="presentation"><a href="#tabViewed" data-toggle="tab">Covers</a></li></ul></div><div class="panel-body"><div class="tab-content"><div class="tab-pane fade in active" id="tabRecent"><div class="media">
<a href="/article/saf-reports-1200-spike-in-members-donors-from-young-adults-since-florida" rel="nofollow"><div class="media-left"><img src="https://canadafreepress.com/images/uploads/saf031218.jpg" class="media-object" style="width:100px"></div><div class="media-body"><strong class="media-heading">SAF Reports 1,200% Spike in Members, Donors From Young Adults Since Florida</strong></div></a></div><div class="media">
<a href="/article/jeff-sessions-immigration-and-california" rel="nofollow"><div class="media-left"><img src="https://canadafreepress.com/images/uploads/GIBBS031118.jpg" class="media-object" style="width:100px"></div><div class="media-body"><strong class="media-heading">Jeff Sessions, Immigration, and California</strong></div></a></div><div class="media">
<a href="/article/seven-show-title-suggestions-for-obamaflix" rel="nofollow"><div class="media-left"><img src="https://canadafreepress.com/images/uploads/calabrese031218-4.jpg" class="media-object" style="width:100px"></div><div class="media-body"><strong class="media-heading">Seven show title suggestions for Obamaflix</strong></div></a></div><div class="media">
<a href="/article/live-video-trump-welcomes-houston-astros-to-the-white-house-.-.-.-will-ther" rel="nofollow"><div class="media-left"><img src="https://canadafreepress.com/images/uploads/calabrese031218-3.jpg" class="media-object" style="width:100px"></div><div class="media-body"><strong class="media-heading">LIVE VIDEO: Trump welcomes Houston Astros to the White House . . . will there be any boycotters?</strong></div></a></div><div class="media">
<a href="/article/sorry-dems-elizabeth-warren-says-no.-youll-have-to-find-someone-else-to-los" rel="nofollow"><div class="media-left"><img src="https://canadafreepress.com/images/uploads/LAURIE031218-3.jpg" class="media-object" style="width:100px"></div><div class="media-body"><strong class="media-heading">Sorry Dems, Elizabeth Warren says no. You&#8217;ll have to find someone else to lose in 2020</strong></div></a></div><div class="media">
<a href="/article/trump-pardons-kristian-saucier-the-sailor-who-took-those-infamous-submarine" rel="nofollow"><div class="media-left"><img src="https://canadafreepress.com/images/uploads/LUAIRE031218-2.jpg" class="media-object" style="width:100px"></div><div class="media-body"><strong class="media-heading">Trump pardons Kristian Saucier - the sailor who took those infamous submarine photos</strong></div></a></div><div class="media">
<a href="/article/life-liberty-levin-sunday-march-11-2018-fox-news" rel="nofollow"><div class="media-left"><img src="https://canadafreepress.com/images/uploads/levin031218.jpg" class="media-object" style="width:100px"></div><div class="media-body"><strong class="media-heading">Life, Liberty &amp; Levin - Sunday, March 11, 2018 - Fox News</strong></div></a></div><div class="media">
<a href="/article/taming-biofuel-loving-microbes" rel="nofollow"><div class="media-left"><img src="https://canadafreepress.com/images/uploads/acs031218-4.jpg" class="media-object" style="width:100px"></div><div class="media-body"><strong class="media-heading">Taming biofuel-loving microbes</strong></div></a></div><div class="media">
<a href="/article/with-a-teng-solar-cells-could-work-come-rain-or-shine" rel="nofollow"><div class="media-left"><img src="https://canadafreepress.com/images/uploads/acs031218-3.jpg" class="media-object" style="width:100px"></div><div class="media-body"><strong class="media-heading">With a TENG, solar cells could work come rain or shine</strong></div></a></div><div class="media">
<a href="/article/brazil-argentina-.-.-.-pretty-much-everyone-exempt-us-from-the-tariffs-too" rel="nofollow"><div class="media-left"><img src="https://canadafreepress.com/images/uploads/calabrese021218.jpg" class="media-object" style="width:100px"></div><div class="media-body"><strong class="media-heading">Brazil, Argentina . . . pretty much everyone: Exempt us from the tariffs too!</strong></div></a></div><div class="media">
<a href="/article/israel-trump-and-united-nations-should-boycott-abbas-and-plo" rel="nofollow"><div class="media-left"><img src="https://canadafreepress.com/images/uploads/singer031118.jpg" class="media-object" style="width:100px"></div><div class="media-body"><strong class="media-heading">Israel, Trump and United Nations should boycott Abbas and PLO</strong></div></a></div><div class="media">
<a href="/article/trumps-proposed-tariffs-are-the-retaliation" rel="nofollow"><div class="media-left"><img src="https://canadafreepress.com/images/uploads/CAIN031118.jpg" class="media-object" style="width:100px"></div><div class="media-body"><strong class="media-heading">Trump&#8217;s proposed tariffs are the retaliation</strong></div></a></div><div class="media">
<a href="/article/why-trump-is-so-hated-by-leftists" rel="nofollow"><div class="media-left"><img src="https://canadafreepress.com/images/uploads/marcus031018.jpg" class="media-object" style="width:100px"></div><div class="media-body"><strong class="media-heading">Why Trump is So Hated by Leftists</strong></div></a></div><div class="media">
<a href="/article/little-rocket-mans-great-big-summit-scam" rel="nofollow"><div class="media-left"><img src="https://canadafreepress.com/images/uploads/rossett031118.jpg" class="media-object" style="width:100px"></div><div class="media-body"><strong class="media-heading">Little Rocket Man&#8217;s Great Big Summit Scam</strong></div></a></div><div class="media">
<a href="/article/politicide-the-attempted-murder-of-the-jewish-state-by-victor-sharpe" rel="nofollow"><div class="media-left"><img src="https://canadafreepress.com/images/uploads/swirsky031118.jpg" class="media-object" style="width:100px"></div><div class="media-body"><strong class="media-heading">Politicide: The attempted murder of the Jewish state by Victor Sharpe</strong></div></a></div><div class="media">
<a href="/article/were-from-the-international-community-and-were-here-to-help" rel="nofollow"><div class="media-left"><img src="https://canadafreepress.com/images/uploads/greenfied031118.jpg" class="media-object" style="width:100px"></div><div class="media-body"><strong class="media-heading">We&#8217;re From the International Community and We&#8217;re Here to Help</strong></div></a></div><div class="media">
<a href="/article/president-donald-trump-rally-in-moon-township" rel="nofollow"><div class="media-left"><img src="https://canadafreepress.com/images/uploads/video031118.jpg" class="media-object" style="width:100px"></div><div class="media-body"><strong class="media-heading">President Donald Trump Rally in Moon Township</strong></div></a></div><div class="media">
<a href="/article/california-has-become-a-disgraceful-state" rel="nofollow"><div class="media-left"><img src="https://canadafreepress.com/images/uploads/crouere031018.jpg" class="media-object" style="width:100px"></div><div class="media-body"><strong class="media-heading">California Has Become A Disgraceful State</strong></div></a></div><div class="media">
<a href="/article/why-trump-has-to-deal-with-north-korea" rel="nofollow"><div class="media-left"><img src="https://canadafreepress.com/images/uploads/dilotenzo031018.jpg" class="media-object" style="width:100px"></div><div class="media-body"><strong class="media-heading">Why Trump Has to Deal With North Korea</strong></div></a></div><div class="media">
<a href="/article/tomorrow-rain-or-shine" rel="nofollow"><div class="media-left"><img src="https://canadafreepress.com/images/uploads/rosebrock031018.jpg" class="media-object" style="width:100px"></div><div class="media-body"><strong class="media-heading">Tomorrow&#8212;Rain or Shine</strong></div></a></div><div class="media">
<a href="/article/california-vs.-usa" rel="nofollow"><div class="media-left"><img src="https://canadafreepress.com/images/uploads/VADUM030918.jpg" class="media-object" style="width:100px"></div><div class="media-body"><strong class="media-heading">California vs. USA</strong></div></a></div><div class="media">
<a href="/article/cnn-laments-trump-will-go-down-as-a-great-president-if-he-solves-the-korean" rel="nofollow"><div class="media-left"><img src="https://canadafreepress.com/images/uploads/LAURIE030918.jpg" class="media-object" style="width:100px"></div><div class="media-body"><strong class="media-heading">CNN laments: Trump will &#8216;go down as a great President&#8217; if he solves the Korean problem. &#8216;There&#8217;s no</strong></div></a></div><div class="media">
<a href="/article/quit-disarming-teachers" rel="nofollow"><div class="media-left"><img src="https://canadafreepress.com/images/uploads/owens030918.jpg" class="media-object" style="width:100px"></div><div class="media-body"><strong class="media-heading">Quit Disarming Teachers</strong></div></a></div><div class="media">
<a href="/article/ag-jeff-sessions-in-ca-to-stop-illegal-sanctuary-state-laws" rel="nofollow"><div class="media-left"><img src="https://canadafreepress.com/images/uploads/grimes030818.jpg" class="media-object" style="width:100px"></div><div class="media-body"><strong class="media-heading">AG Jeff Sessions in CA To Stop Illegal Sanctuary State Laws</strong></div></a></div></div><div class="tab-pane fade" id="tabNews"><div class="media"><div class="media-body"><h5 class="media-heading"><a href="/article/record-breaking-crowd-of-100000-pro-life-people-rally-in-ireland-against-le" rel="nofollow">Record-Breaking Crowd of 100,000 Pro-Life People Rally in Ireland Against Legalizing Abortion</a></h5></div></div><div class="media"><div class="media-body"><h5 class="media-heading"><a href="/article/shooting-at-florida-business-leaves-1-dead-2-injured" rel="nofollow">Shooting at Florida business leaves 1 dead, 2 injured</a></h5></div></div><div class="media"><div class="media-body"><h5 class="media-heading"><a href="/article/video-hillary-slips-down-stairs-in-india-despite-two-men-holding-her-up" rel="nofollow">VIDEO: Hillary slips down stairs in India &#8212; despite two men holding her up</a></h5></div></div><div class="media"><div class="media-body"><h5 class="media-heading"><a href="/article/house-republicans-say-probe-found-no-evidence-of-collusion-between-trump-ru" rel="nofollow">House Republicans say probe found no evidence of collusion between Trump, Russia</a></h5></div></div><div class="media"><div class="media-body"><h5 class="media-heading"><a href="/article/beloved-pastors-wife-killed-minister-beaten-in-north-carolina-home-invasion" rel="nofollow">Beloved pastor&#8217;s wife killed, minister beaten in North Carolina home invasion and arson</a></h5></div></div><div class="media"><div class="media-body"><h5 class="media-heading"><a href="/article/twitter-censors-drudge-tweet-of-trump-2020-slogan-as-sensitive-material" rel="nofollow">Twitter Censors Drudge Tweet of Trump 2020 Slogan as &#8216;Sensitive Material&#8217;</a></h5></div></div><div class="media"><div class="media-body"><h5 class="media-heading"><a href="/article/austin-package-explosions-leave-teen-dead-women-hurt-after-three-blasts-in" rel="nofollow">Austin package explosions leave teen dead, women hurt after three blasts in 2 weeks</a></h5></div></div><div class="media"><div class="media-body"><h5 class="media-heading"><a href="/article/rescue-dog-saves-family-from-massive-house-fire" rel="nofollow">Rescue dog saves family from massive house fire</a></h5></div></div><div class="media"><div class="media-body"><h5 class="media-heading"><a href="/article/austin-package-explosion-leaves-teen-dead-woman-hurt-after-second-blast-in" rel="nofollow">Austin package explosion leaves teen dead, woman hurt after second blast in 2 weeks</a></h5></div></div><div class="media"><div class="media-body"><h5 class="media-heading"><a href="/article/man-swept-away-by-wave-in-bahamas-had-asked-permission-to-marry-girlfriend" rel="nofollow">Man swept away by wave in Bahamas had asked permission to marry girlfriend before death, family says</a></h5></div></div><div class="media"><div class="media-body"><h5 class="media-heading"><a href="/article/expert-warns-of-terrifying-potential-of-digitally-altered-video" rel="nofollow">Expert warns of &#8220;terrifying&#8221; potential of digitally-altered video</a></h5></div></div><div class="media"><div class="media-body"><h5 class="media-heading"><a href="/article/all-this-is-likely-to-end-very-very-bad-for-her-zim-state-media-turns-on-gr" rel="nofollow">&#8216;All this is likely to end very, very bad for her&#8217;: Zim state media turns on Grace Mugabe</a></h5></div></div><div class="media"><div class="media-body"><h5 class="media-heading"><a href="/article/student-barred-from-class-for-claiming-there-are-two-genders" rel="nofollow">Student barred from class for claiming there are two genders</a></h5></div></div><div class="media"><div class="media-body"><h5 class="media-heading"><a href="/article/canada-poised-to-launch-emergency-alert-system-on-smartphones" rel="nofollow">Canada poised to launch emergency alert system on smartphones</a></h5></div></div><div class="media"><div class="media-body"><h5 class="media-heading"><a href="/article/zim-army-detains-mugabe-staff-without-food-water-...-interrogates-them-for" rel="nofollow">Zim army detains Mugabe staff without food, water ... interrogates them for hours - reports</a></h5></div></div><div class="media"><div class="media-body"><h5 class="media-heading"><a href="/article/helicopter-crashes-in-new-york-citys-east-river-all-5-passengers-dead-pilot" rel="nofollow">Helicopter crashes in New York City&#8217;s East River; all 5 passengers dead, pilot only survivor</a></h5></div></div><div class="media"><div class="media-body"><h5 class="media-heading"><a href="/article/christine-elliott-concedes-to-ontario-pc-leader-doug-ford" rel="nofollow">Christine Elliott concedes to Ontario PC Leader Doug Ford</a></h5></div></div><div class="media"><div class="media-body"><h5 class="media-heading"><a href="/article/rwanda-seventh-day-adventist-churchgoers-killed-by-lightning" rel="nofollow">Rwanda Seventh-Day Adventist churchgoers killed by lightning</a></h5></div></div><div class="media"><div class="media-body"><h5 class="media-heading"><a href="/article/euthanasia-activists-want-to-force-doctors-to-participate-in-assisted-suici" rel="nofollow">Euthanasia Activists Want to Force Doctors to Participate in Assisted Suicides</a></h5></div></div><div class="media"><div class="media-body"><h5 class="media-heading"><a href="/article/brussels-on-the-brink-eus-hostile-front-against-uk-faces-collapse-as-italy" rel="nofollow">Brussels on the Brink: EU&#8217;s Hostile Front Against UK Faces Collapse as Italy Election Winners </a></h5></div></div></div><div class="tab-pane fade" id="tabViewed"><div class="media">
<a href="/article/did-obama-learn-the-ropes-for-his-netflix-job-from-daughter-malia" rel="nofollow"><div class="media-left"><img src="https://canadafreepress.com/images/uploads/cover031218.jpg" class="media-object" style="width:100px"></div><div class="media-body"><strong class="media-heading">Did Obama Learn the Ropes for his Netflix Job from Daughter Malia?</strong></div></a></div><div class="media">
<a href="/article/keeping-dissidents-busy" rel="nofollow"><div class="media-left"><img src="https://canadafreepress.com/images/uploads/rosamund031218.jpg" class="media-object" style="width:100px"></div><div class="media-body"><strong class="media-heading">Keeping Dissidents Busy</strong></div></a></div><div class="media">
<a href="/article/russia-collusion-inquisition-is-french-dreyfus-affair-in-reverse" rel="nofollow"><div class="media-left"><img src="https://canadafreepress.com/images/uploads/lustvardi031218.jpg" class="media-object" style="width:100px"></div><div class="media-body"><strong class="media-heading">Russia Collusion Inquisition is French Dreyfus Affair in Reverse</strong></div></a></div><div class="media">
<a href="/article/graham-is-gone-are-the-two-power-prophets-next" rel="nofollow"><div class="media-left"><img src="https://canadafreepress.com/images/uploads/bresciani031218.jpg" class="media-object" style="width:100px"></div><div class="media-body"><strong class="media-heading">Graham is Gone&#8212;Are the Two Power Prophets Next?</strong></div></a></div><div class="media">
<a href="/article/trickle-down-trump" rel="nofollow"><div class="media-left"><img src="https://canadafreepress.com/images/uploads/ONEILL031118.jpg" class="media-object" style="width:100px"></div><div class="media-body"><strong class="media-heading">Trickle-Down Trump</strong></div></a></div><div class="media">
<a href="/article/elizabeth-warren-strangely-disinterested-in-taking-a-dna-test-to-prove-her" rel="nofollow"><div class="media-left"><img src="https://canadafreepress.com/images/uploads/LAURIE031218.jpg" class="media-object" style="width:100px"></div><div class="media-body"><strong class="media-heading">Elizabeth Warren strangely disinterested in taking a DNA test to prove her Native American heritage</strong></div></a></div><div class="media">
<a href="/article/how-i-responded-to-the-petition-womans-declaration-that-the-people-have-pow" rel="nofollow"><div class="media-left"><img src="https://canadafreepress.com/images/uploads/CALABRESE031218-2.jpg" class="media-object" style="width:100px"></div><div class="media-body"><strong class="media-heading">How I responded to the petition woman&#8217;s declaration that &#8216;the people have power&#8217;</strong></div></a></div><div class="media">
<a href="/article/making-ontario-sane-again" rel="nofollow"><div class="media-left"><img src="https://canadafreepress.com/images/uploads/cover031118.jpg" class="media-object" style="width:100px"></div><div class="media-body"><strong class="media-heading">Making Ontario Sane Again</strong></div></a></div><div class="media">
<a href="/article/the-night-that-god-came-to-the-camp-fire" rel="nofollow"><div class="media-left"><img src="https://canadafreepress.com/images/uploads/merrick031118.jpg" class="media-object" style="width:100px"></div><div class="media-body"><strong class="media-heading">The Night That God Came to the Camp Fire</strong></div></a></div><div class="media">
<a href="/article/social-media-all-hat-no-head" rel="nofollow"><div class="media-left"><img src="https://canadafreepress.com/images/uploads/COVER030918.jpg" class="media-object" style="width:100px"></div><div class="media-body"><strong class="media-heading">Social Media All Hat No Head</strong></div></a></div><div class="media">
<a href="/article/behars-apology-to-pence-should-have-been-public-and-millions-await-co-host" rel="nofollow"><div class="media-left"><img src="https://canadafreepress.com/images/uploads/COVER030818.jpg" class="media-object" style="width:100px"></div><div class="media-body"><strong class="media-heading">Behar&#8217;s Apology to Pence Should Have Been Public, and Millions Await Co-host Hostin&#8217;s</strong></div></a></div><div class="media">
<a href="/article/no-protection-for-babies-or-cops-in-twitter-land" rel="nofollow"><div class="media-left"><img src="https://canadafreepress.com/images/uploads/cover030718.jpg" class="media-object" style="width:100px"></div><div class="media-body"><strong class="media-heading">No protection for Babies or Cops in Twitter Land</strong></div></a></div><div class="media">
<a href="/article/watch-out-fellas-jimmy-kimmel-would-make-you-an-eunuch-by-changing-gods-plu" rel="nofollow"><div class="media-left"><img src="https://canadafreepress.com/images/uploads/cover030518.jpg" class="media-object" style="width:100px"></div><div class="media-body"><strong class="media-heading">Watch out fellas: Jimmy Kimmel would make you an Eunuch by Changing God&#8217;s Plumbing</strong></div></a></div><div class="media">
<a href="/article/canadas-mr.-dress-up-has-no-big-boy-budget-pants" rel="nofollow"><div class="media-left"><img src="https://canadafreepress.com/images/uploads/cover030318-1.jpg" class="media-object" style="width:100px"></div><div class="media-body"><strong class="media-heading">Canada&#8217;s Mr. Dress Up Has No Big Boy Budget Pants</strong></div></a></div><div class="media">
<a href="/article/academy-awards-2018-me-and-my-uterus" rel="nofollow"><div class="media-left"><img src="https://canadafreepress.com/images/uploads/cover030418.jpg" class="media-object" style="width:100px"></div><div class="media-body"><strong class="media-heading">Academy Awards 2018: &#8216;Me and My Uterus&#8217;</strong></div></a></div><div class="media">
<a href="/article/make-trump-tv-a-permanent-feature-mr.-president" rel="nofollow"><div class="media-left"><img src="https://canadafreepress.com/images/uploads/COVER030218.jpg" class="media-object" style="width:100px"></div><div class="media-body"><strong class="media-heading">Make TRUMP TV a Permanent Feature, Mr. President!</strong></div></a></div><div class="media">
<a href="/article/the-cunning-deceit-of-facebooks-big-algorithm-game" rel="nofollow"><div class="media-left"><img src="https://canadafreepress.com/images/uploads/cover030118.jpg" class="media-object" style="width:100px"></div><div class="media-body"><strong class="media-heading">The Cunning Deceit of Facebook&#8217;s Big Algorithm Game</strong></div></a></div><div class="media">
<a href="/article/broward-county-sheriffs-trained-area-mosque-attendees-how-to-protect-themse" rel="nofollow"><div class="media-left"><img src="https://canadafreepress.com/images/uploads/cover022818.jpg" class="media-object" style="width:100px"></div><div class="media-body"><strong class="media-heading">Broward County Sheriffs Trained Area Mosque Attendees How To Protect Themselves</strong></div></a></div><div class="media">
<a href="/article/obama-now-data-mining-president-trumps-voter-base" rel="nofollow"><div class="media-left"><img src="https://canadafreepress.com/images/uploads/cover022718.jpg" class="media-object" style="width:100px"></div><div class="media-body"><strong class="media-heading">Obama Now Data Mining President Trump&#8217;s Voter Base</strong></div></a></div><div class="media">
<a href="/article/monica-lewinskys-chance-encounter-with-ken-starr-makes-it-to-vanity-fair-as" rel="nofollow"><div class="media-left"><img src="https://canadafreepress.com/images/uploads/cover022618.jpg" class="media-object" style="width:100px"></div><div class="media-body"><strong class="media-heading">Monica Lewinsky&#8217;s Chance Encounter with Ken Starr Makes it to Vanity Fair as #Me-Too Story</strong></div></a></div><div class="media">
<a href="/article/the-sorry-state-of-the-deep-state" rel="nofollow"><div class="media-left"><img src="https://canadafreepress.com/images/uploads/COVE022518.jpg" class="media-object" style="width:100px"></div><div class="media-body"><strong class="media-heading">The Sorry State of the Deep State</strong></div></a></div><div class="media">
<a href="/article/sheriff-israels-duty-ducking-deputies-his-scapegoats" rel="nofollow"><div class="media-left"><img src="https://canadafreepress.com/images/uploads/cover022318.jpg" class="media-object" style="width:100px"></div><div class="media-body"><strong class="media-heading">Sheriff Israel&#8217;s &#8216;Duty-Ducking Deputies&#8217; His Scapegoats?</strong></div></a></div><div class="media">
<a href="/article/the-one-message-that-stays-viral-in-a-dog-eat-dog-digital-world" rel="nofollow"><div class="media-left"><img src="https://canadafreepress.com/images/uploads/cover022218.jpg" class="media-object" style="width:100px"></div><div class="media-body"><strong class="media-heading">The One Message That Stays Viral in a Dog-Eat-Dog Digital World</strong></div></a></div><div class="media">
<a href="/article/in-mocking-christians-bully-bigot-joy-behar-claims-she-was-only-joking" rel="nofollow"><div class="media-left"><img src="https://canadafreepress.com/images/uploads/cover022018.jpg" class="media-object" style="width:100px"></div><div class="media-body"><strong class="media-heading">In Mocking Christians, Bully Bigot Joy Behar Claims She Was Only Joking</strong></div></a></div></div></div></div></div></div></div></div><div class="row"><div class="col-md-12 col-sm-6 col-xs-12">
<div id="smi2adblock_82306" align="center"><a href="http://idealmedia.com/">News from idealmedia.com</a></div>
<script type="text/javascript" charset="utf-8">
  (function() {
    var sc = document.createElement('script'); sc.type = 'text/javascript'; sc.async = true;
    sc.src = '//news.fark.com/data/js/82306.js'; sc.charset = 'utf-8';
    var s = document.getElementsByTagName('script')[0]; s.parentNode.insertBefore(sc, s);
  }());
</script></div><div class="col-md-12 col-sm-6 col-xs-12"></div></div><div class="row"><div class="col-md-12 col-sm-6 col-xs-12">
<a href="http://canadafreepress.com/infrastructure/"><img src="https://canadafreepress.com//resource/water-break-clock.jpg" class="imgbig" alt="Infrastructure" title="Infrastructure"></a><br /><hr /></div><div class="col-md-12 col-sm-6 col-xs-12"><div data-spotim-module="siderail" data-spot-id="sp_amADK71w"></div> <script async src="https://mc-siderail.spot.im/spot/sp_amADK71w" data-spotim-script="siderail"></script> </div></div>
</aside>
<div id="unit_85922"><a href="http://idealmedia.com/">News from idealmedia.com</a></div>
<script type="text/javascript" charset="utf-8">
  (function() {
    var sc = document.createElement('script'); sc.type = 'text/javascript'; sc.async = true;
    sc.src = '//news.idealmedia.com/data/js/85922.js'; sc.charset = 'utf-8';
    var s = document.getElementsByTagName('script')[0]; s.parentNode.insertBefore(sc, s);
  }());
</script></div></div><footer class="pagefoot container-fluid"><div class="row"><div class="container"><div class="col-md-12 ">
<img src="https://canadafreepress.com/resource/cfp-logo.png" alt="Canada Free Press" class="pull-left rotund-full"><h3 style="line-height:3em; margin: 0 0 15px 15px;float:left;">Canada Free Press</h3></div></div></div><div class="row"><div class="container">
<nav class="col-md-6"><div class="row"><div class="col-md-6 col-xs-6">
<a href="/">Home</a>
<a href="https://canadafreepress.com/categories/coverstory">Cover Stories</a>
<a href="https://canadafreepress.com/categories/american-politics">America</a>
<a href="https://canadafreepress.com/categories/canadian-news">Canada</a>
<a href="https://canadafreepress.com/categories/world">World</a>
<a href="https://canadafreepress.com/categories/guns-crime-terror-security">Crime &amp; Terror</a>
<a href="https://canadafreepress.com/categories/Global-Warming-Energy-Environment">Environment</a></div><div class="col-md-6 col-xs-6">
<a href="https://canadafreepress.com/categories/news-headlines">Headlines</a>
<a href="https://canadafreepress.com/categories/natural-science-technology">Science &amp; Tech</a>
<a href="https://canadafreepress.com/categories/Lifestyle-Health-Travel-Pets">Life, Pets</a>
<a href="https://canadafreepress.com/categories/health-medicine">Health Medicine</a>
<a href="https://canadafreepress.com/categories/Travel">Travel</a>
<a href="https://canadafreepress.com/categories/Automotive">Cars &amp; Reviews</a>
<a href="https://canadafreepress.com/privacy.htm" target="_blank">Privacy Statement</a></div></div>
</nav><div class="col-md-6"> <script type="text/javascript" src="https://static.mailerlite.com/data/webforms/396128/o1p1n0.js?v5"></script> </div><div class="col-md-12"><hr><div class="row"><p class="small">Pursuant to Title 17 U.S.C. 107, other copyrighted work is provided for educational purposes, research, critical comment, or debate without profit or payment. If you wish to use copyrighted material from this site for your own purposes beyond the 'fair use' exception, you must obtain permission from the copyright owner. Views are those of authors and not necessarily those of Canada Free Press. Content is Copyright 1997-2018 the individual authors. Site Copyright 1997-2018 Canada Free Press.Com <a href="http://canadafreepress.com/privacy.htm" target="_blank">Privacy Statement</a></p></div></div></div></div>
</footer> <script src="https://ajax.googleapis.com/ajax/libs/jquery/1.11.3/jquery.min.js"></script> <script src="/bootstrap/js/bootstrap.min.js"></script> <script type="text/javascript" src="//s7.addthis.com/js/300/addthis_widget.js#pubid=bthom62"></script> <script src='//get.s-onetag.com/57114b53-4821-4841-9f9d-e78cad23c6a3/tag.min.js' async defer></script> <script>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</script>
</body></html>